Any sysaiders expierenced this dery migration fail? (No current connection)

Hey fellow Sysaiders!

Yesterday I started to migrate our Sysaid 9.0 to 9.1 which was a succes. Then I wanted to run the 14.1 upgrade but I'm getting stuck here on a migration faild error screen in setup.

Bellow my log with the error:

Failed to delete policy_id column in computer / computer_history - Java exception: 'Index: 70, Size: 25: java.lang.IndexOutOfBoundsException'.

Error in main - java.sql.SQLNonTransientConnectionException: No current connection.
showProcess action = MigrationProgressEvent, value = 11004
Migration failed: No current connection.
java.sql.SQLNonTransientConnectionException: No current connection.
at org.apache.derby.impl.jdbc.SQLExceptionFactory40.getSQLException(Unknown Source)
at org.apache.derby.impl.jdbc.Util.newEmbedSQLException(Unknown Source)
at org.apache.derby.impl.jdbc.Util.newEmbedSQLException(Unknown Source)
at org.apache.derby.impl.jdbc.Util.noCurrentConnection(Unknown Source)
at org.apache.derby.impl.jdbc.EmbedConnection.checkIfClosed(Unknown Source)
at org.apache.derby.impl.jdbc.EmbedConnection.getMetaData(Unknown Source)
at com.sysaid.util.MigrateData.mainReal(Unknown Source)
at com.sysaid.util.MigrateData.main(Unknown Source)
at com.sysaid.util.MigrateDerbyToMssql.main(Unknown Source)
Caused by: java.sql.SQLException: No current connection.
at org.apache.derby.impl.jdbc.SQLExceptionFactory.getSQLException(Unknown Source)
at org.apache.derby.impl.jdbc.SQLExceptionFactory40.wrapArgsForTransportAcrossDRDA(Unknown Source)
... 9 more
Process started at: 09.04.2014 12:39, Process ended at: 09.04.2014 12:40

I tried to turn of the sysaid service but to no avail. The server always had sysaid running with the database stored local and is in our windows domain. This always worked fine for us.

This message was edited 1 time. Last update was at Apr. 10, 2014 07:47 AM

Has anyone figured out a way past this error? I am having the same problem.
Former Community Manager
Are you upgrading the free edition and using 14.1.10? There was an issue in which during the upgrade on the free edition, the target database wasn't being created, which errored the install.

Thank you.

I am having the same issue. I am upgrading from 9.1.02 (paid version) to 14.1.10. Any suggestions?
Former Community Manager
Hi Marj,

Check if there's a migration log file. I believe named derbytosqlmigration.log, at c:\program files\sysaidserver\web-inf\logs (or c:\program files (x86) for 32 bit Windows)). Check if there are any errors, or feel free to post or DM the log to me and I can take a quick look.