Problema nell'invio delle email

 
Author
Message
SysAider
6
 
Salve a tutti,
ho appena installato Sysaid ed ho un piccolo problema.
Ho configurato correttamente l'integrazione email con un account gmail dedicato e riesco sia a ricevere che a spedire posta. C'è un però, quando sono su un ticket e clicco su una delle varie possibilità "invia mail", selezione il mio indirizzo che è memorizzato ed invio una mail, la finestrella poup up mi dice che è stata inviata correttamente, ma nella mia casella non arriva nulla.
Qualcuno ha idea di cosa può essere successo? Ma soprattutto mi sapete dire dove posso vedere i log per capire cosa succede?

Grazie,
Laura
SysAider
25
 
Buongiorno Laura,

Ti consiglio di consultare la guida online di SysAid per verificare se l'integrazione è stata correttamente configurata: https://www.sysaid.com/onlineaid/legacy3/IntegrationEmailEdit.htm

I file di log possono essere scaricati direttamente da SysAid accedendo a Preferences (nome dell'utente con cui è loggata in alto a destra) -> About -> Download log files.
Puoi cortesemente postarli qui così posso esserti più d'aiuto?

L'email che invii da SysAid è disponibile nel tab Messages del ticket?
Le notifiche automatiche funzionano?

Grazie

Matteo

This message was edited 1 time. Last update was at Nov. 05, 2015 09:42 AM

SysAider
6
 
Ciao Matteo,
il tuo intervento è stato prezioso e ti ringrazio!
Andando per ordine con le istruzioni, mi sembra che l'integrazione sia correttamente configurata.
Tra l'altro sono certa che fino ad una settimana fa sono riuscita ad inviare messaggi.
Tutti i messaggi inviati, ma che non sono mai partiti, sono disponibili nel Tab Messages del ticket e inoltre il poup up mi dice OK, messaggio inviato.
Di seguito ho estrapolato dei log.
Grazie mille per l'attenzione,

Laura


Di seguito il log:
2015-11-06 15:56:53,403 [DefaultQuartzScheduler_Worker-10] INFO com.ilient - [free] [ImspMailAgent] <loadProtocolParameters> load 'imap' email parameters.
2015-11-06 15:57:53,487 [DefaultQuartzScheduler_Worker-6] INFO com.ilient - [free] [ImspMailAgent] <loadProtocolParameters> load 'imap' email parameters.
2015-11-06 15:58:41,792 [http-bio-8080-exec-21] INFO com.ilient - [free] The method getChatErrorTooltipForUserName - can't display the chat link because Laura PE is offline
2015-11-06 15:58:41,792 [http-bio-8080-exec-21] INFO com.ilient - [free] The method getRCTooltipForUserName - can't display the rc link because Laura PE is offline
2015-11-06 15:58:41,793 [http-bio-8080-exec-21] INFO com.ilient - [free] The method getChatErrorTooltipForUserName - can't display the chat link because Laura PE is offline
2015-11-06 15:58:41,793 [http-bio-8080-exec-21] INFO com.ilient - [free] The method getRCTooltipForUserName - can't display the rc link because Laura PE is offline
2015-11-06 15:58:53,403 [DefaultQuartzScheduler_Worker-4] INFO com.ilient - [free] [ImspMailAgent] <loadProtocolParameters> load 'imap' email parameters.
2015-11-06 15:58:55,168 [http-bio-8080-exec-24] ERROR com.ilient - Exception while sending email, message:javax.mail.AuthenticationFailedException cannot be cast to com.sun.mail.smtp.SMTPSendFailedException
java.lang.ClassCastException: javax.mail.AuthenticationFailedException cannot be cast to com.sun.mail.smtp.SMTPSendFailedException
at com.ilient.server.aP.a(Unknown Source)
at com.ilient.server.aP.a(Unknown Source)
at com.ilient.jsp.Compose_jsp._jspService(Unknown Source)
at org.apache.jasper.runtime.HttpJspBase.service(HttpJspBase.java:70)
at javax.servlet.http.HttpServlet.service(HttpServlet.java:727)
at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:303)
at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:20
at org.apache.tomcat.websocket.server.WsFilter.doFilter(WsFilter.java:52)
at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:241)
at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:20
at com.ilient.server.LoginFilter.doFilter(Unknown Source)
at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:241)
at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:20
at com.ilient.server.XssHtmlParamFilter.doFilter(Unknown Source)
at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:241)
at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:20
at org.apache.catalina.core.StandardWrapperValve.invoke(StandardWrapperValve.java:220)
at org.apache.catalina.core.StandardContextValve.invoke(StandardContextValve.java:122)
at org.apache.catalina.authenticator.AuthenticatorBase.invoke(AuthenticatorBase.java:503)
at org.apache.catalina.core.StandardHostValve.invoke(StandardHostValve.java:170)
at org.apache.catalina.valves.ErrorReportValve.invoke(ErrorReportValve.java:103)
at org.apache.catalina.core.StandardEngineValve.invoke(StandardEngineValve.java:116)
at org.apache.catalina.connector.CoyoteAdapter.service(CoyoteAdapter.java:421)
at org.apache.coyote.http11.AbstractHttp11Processor.process(AbstractHttp11Processor.java:1070)
at org.apache.coyote.AbstractProtocol$AbstractConnectionHandler.process(AbstractProtocol.java:611)
at org.apache.tomcat.util.net.JIoEndpoint$SocketProcessor.run(JIoEndpoint.java:316)
at java.util.concurrent.ThreadPoolExecutor.runWorker(Unknown Source)
at java.util.concurrent.ThreadPoolExecutor$Worker.run(Unknown Source)
at org.apache.tomcat.util.threads.TaskThread$WrappingRunnable.run(TaskThread.java:61)
at java.lang.Thread.run(Unknown Source)
SysAider
25
 
Buongiorno Laura,

L'errore presente nei file di log indica il fatto che non ci si riesce a collegare al server mail con le credenziali specificate nell'Integrazione email.
Potresti cortesemente postarmi uno screenshot dell'integrazione email così proviamo a capire dove è il problema?
Per sicurezza prova a reinserire anche l'utente e la password per l'Outgoing email.

Grazie.

Matteo
SysAider
6
 
Ciao,
oggi facendo vari tentativi ho provato a cambiare la modalità di invio da HTML a text e magicamente l'invio delle email funziona correttamente! Evidentemente Gmail non consente l'invio in HTML.
Grazie comunque per il supporto,

Laura
SysAider
2
 
Buongiorno ,

attualmente funzionano solo le email in uscita con un indirizzo email , configurato correttamente .

adesso vorremmo dare la possibilità anche agli utenti di rispondere alle email che gli inviamo da sysyaid ma non funziona correttamente.

se imposto la stessa mail si in uscita che in ingresso funziona correttamente ma mi elimina tutte le mail precedenti. non tiene uno storico nella casella di posta di help ced.

invece se imposto una mail per uscita e una diversa per ingresso , in uscita funziona correttamente, in ingresso arriva alla casella ma non arriva in sysaid .
qualcosa sbaglio sicuramente.

grazie

Elite SysAider
147
 
consorzio.cbbg,
abbiamo cercato di contattarti telefonicamente per verificare i parametri dell'integrazione email in arrivo (POP, IMAP, etc.) Controlla la mail