Gmail Integration Failing

 
Author
Message
SysAider
7
 
Hi,

I am having issues integrating SysAid with Gmail for both incoming and outgoing email.

Ihave tried all encryption types and ports from suggestions i have found online and i have also made sure pop3 and imap have been enabled within gmail.

Please see attached my current integration settings which i belive are correct for incoming mail on imap and outgoing mail on TLS.

If anyone can help that would be great as i would like to test the solution properly.

Thanks.
SysAid Product Manager Community Manager
5276
 
Hi Dunney,

From your description, the integration should work. Please double-check your POP/IMAP settings in gmail, as well as let us know if the email you send to the box is simply left in the inbox in gmail.

Additionally, are we talking about SysAid Cloud, or On-Premise?

Thanks,
Danny
SysAider
7
 
Hi Danny,

This is for SysAid Cloud.

I have double checked the POP/IMAP setting in Gmail and am certain they are correct. Yes any mail that gets sent to Gmail stays in the inbox.
SysAid Product Manager Community Manager
5276
 
Thanks, this appeared to be a problem on our side. The issue should now be fixed, please check and let me know

I apologize for the inconvenience.

Cheers,
Danny
SysAider
7
 
Hi Danny,

Yes i have just had an influx of test emails

Thank you, i can now start testing the system properly. I appreciate the help.
SysAider
7
 
Hi Danny,

How often does the SysAid server poll the Gmail server?

Is this a setting i can change?
SysAid Product Manager Community Manager
5276
 
Cloud scheduler runs every 5 minutes. This timeframe cannot be changed.

Cheers,
Danny
SysAider
6
 
I am having the same problem but with a locally installed version of SysAid.

I have tried several configurations following the recommended Gmail setup with our newly created Gmail account created specifically for SysAid.

It would be very helpful if there was a test connection button that would give some sort of feedback as to whether the settings are correct or not.

I have tried settings with and without SSL and the recommended ports but even though I can look at the test emails on the Gmail server, these messages are not downloaded to SysAid in the form of tickets.

Please help
SysAid Product Manager Community Manager
5276
 
Hi GhostInTheMachines,

First of all, the obvious - make sure the actual checkbox for incoming email integration is ticked
Then, try setting the protocol to IMAP (and make sure it's enabled in your gmail), mail server to imap.gmail.com, and Type of encrypted connection to SSL. Make sure that in User field you're also including the "@gmail.com" part. Also, double-check that you're using the correct password. Afterwards, click Save and give it 5-10 minutes.

If this fails, please also check this page that controls access for less secure apps, and if the option is set to "off", please set it to "on" and check if the problem resolves.

Let me know if this helps.

Cheers,
Danny

This message was edited 1 time. Last update was at Oct. 19, 2016 08:42 AM

SysAider
6
 
I was out of town last week but I changed most of the settings this morning.

We have a custom domain on our gmail account which means the address is @tsbvi.edu, are you saying that I should enter our user as @gmail.com even though all of our email addresses are branded with our domain?
SysAid Product Manager Community Manager
5276
 
Ah, in this case you should enter the email address the same as it's registered

Cheers,
Danny
SysAider
6
 
OK, so I am back to the original question. Is there a way to test the connection inside of SysAid, because right now I change the settings and send the help desk a message but it would be more effective if I could initiate a download of all messages on the server because right now I have about two dozen messages sitting on the server and none of them are being brought into SysAid as far as I can tell.
SysAid Product Manager Community Manager
5276
 
Let's check your SysAid logs for that. The logs can be found under \SysAidServer\root\WEB-INF\logs\sysaid.log.

You can upload the file to a file-hosting service such as Google Drive or Dropbox, and send me a shareable link by a private message for investigation.

By the way, did you change the secure apps setting mentioned earlier in this thread?

Cheers,
Danny
SysAider
6
 
I did change the secure apps setting as you requested.

Here is a link to the log file

https://drive.google.com/file/d/0B9wcUiZurAKwUzlBSkNscS1pdFk/view?usp=sharing
SysAid Product Manager Community Manager
5276
 
You can see the error here:
2016-10-25 10:00:49,411 [DefaultQuartzScheduler_Worker-1] INFO com.ilient - [free] [ImspMailAgent] <loadProtocolParameters> load 'imap' email parameters.
2016-10-25 10:00:49,715 [DefaultQuartzScheduler_Worker-1] ERROR com.ilient - [free,webhelp@tsbvi.edu@imap.gmail.com] E-Mail imap (SSL) login failed on webhelp@tsbvi.edu@imap.gmail.com
2016-10-25 10:00:49,715 [DefaultQuartzScheduler_Worker-1] ERROR com.ilient - [free,webhelp@tsbvi.edu@imap.gmail.com] [ALERT] Please log in via your web browser: https://support.google.com/mail/accounts/answer/78754 (Failure)


It appears like it reaches the server, but is unable to login using your credentials. I suggest following Google's troubleshooting to attempt to resolve it.

Let me know if this works.

Cheers,
Danny