Reset the Main SysAid Administrator Password

 
Author
Message
SysAid Technical Writer
1079
 

Reset the Main SysAid Administrator Password

The SysAid login page allows you to reset your password if you've forgotten it. This is true for any password stored in SysAid except for the main administrator password (the main administrator is the administrator you created during SysAid installation). If you forget this password, you must use the SysAid password reset utility as described below. This utility is also useful if you've forgotten the username of the main administrator.

 

Windows

If you have forgotten the main administrator's username or if you need to reset the main administrator's password, please do the following:

  1. Open the command prompt (Run > CMD).
  2. Note: On Windows Vista, you need to run CMD as an administrator. Go to Start > All programs > Accessories and right-click Command Prompt and select Run as Administrator.

  3. Change the directory to C:\Program Files\SysAidServer\util.
  4. Type ResetPassword.exe and press Enter. Your account name should then be listed.
  5. Type ResetPassword.exe "ACCOUNT NAME" (with the quotes) and press Enter.
  6. The main administrator password has been reset. The username and new password ("changeit") for the main administrator are now displayed.

Linux

The script to reset the main administrator password is located at http://cdn3.sysaid.com/resetpassword.sh. The script should be run with the following two parameters:

    Note: You need to stop Tomcat before running the script. Your terminal environment also needs to support Java commands. If you can run "java -version" from the terminal, then the script should work.

  1. The path to the root SysAid folder. In Linux, it is usually the SysAid folder under the Tomcat webapps (e.g. /var/tomcat/webapps/sysaid).
  2. The account name (e.g. Acme).

 

Example: ./resetpassword.sh /var/tomcat/webapps/sysaid Acme

 

The script shows you the administrator username and the new password (which is "changeit").

SysAider
2
 
Dear EisenmanAvi
I followed your instructions to reset the SysAid administrator password on Linux, but I'm facing some problems:
- operating system - Ubuntu 16.04
- SysAid version ON-PREMISE Winter16 Trial
- java version "1.8.0_131"
- Java (TM) SE Runtime Environment (build 1.8.0_131-b11)
- Java HotSpot (TM) 64-Bit Server VM (build 25.131-b11, mixed mode)
- Tomcat7 - 7.0.68-1ubuntu0.1
- MySQL - 5.7.18-0ubuntu0.16.04.1
When I run the script I get the following message
Root @ ip-10-0-0-69: / home / ubuntu # ./resetpassword.sh / var / lib / tomcat7 / webapps / ROOT sysaid
./resetpassword.sh: 8: ./resetpassword.sh: / var / lib / tomcat7 / webapps / ROOT / bin / java: not found
I have created a bin directory under / var / lib / tomcat7 / webapps / ROOT / bin and created a symbolic link for java, but now I have the following message:
Root @ ip-10-0-0-69: / home / ubuntu # ./resetpassword.sh / var / lib / tomcat7 / webapps / ROOT sysaid
Error: Could not find or load main class com.ilient.util.ResetPassword
Can you help me please.
Thank you a lot
Best Regards

This message was edited 1 time. Last update was at Jun. 11, 2017 08:14 PM

SysAid Product Manager Community Manager
5252
 
Hi AMCSNG,

Try this:
/var/lib/tomcat7/webapps/sysaid/util$ sudo ./ResetPassword.sh /usr/ account_id

Replace the account_id with your actual SysAid account ID.

Cheers,
Danny
SysAider
2
 
Hi Danny

Thank you very much, for your attention.

Cheers
Alexandre de Moraes
SysAider
1
 
Does this reset the MS SQL express password (are they the same?).

I'd like to run some queries against the SQL installation we're using but can't currently connect to the local DB. My colleague set this up and didn't specify a password.
SysAid Product Manager Community Manager
5252
 
Hi Gavin,

This is not the same password, no. Which queries do you wish to run on the DB, and which version of SysAid do you have?

Thanks,
Danny
SysAider
1
 
Hi I mange to install new version of Sysaid on a newly installed OS and also got everything up and running and one of the steps i wanted to do was to move the old Sysaid database from my old 2008 server to new win 2012 server which at this point im stuck as i don't recall what password was used to setup this SQL Sysaid database and therefore not able to connect to backup/ and than import onto my new server running new OS and new SQL . I tried few articles where i had gone into to .C:\Program Files (x86)\SysAidServer\root\WEB-INF\conf and changed the password which i was able to but after i did my edits it didn't re encrypt it as the old one and it dint work ,Any help would be much appreciated.

Thanks
Raza
SysAid Product Manager Community Manager
5252
 
Hi Raza,

I've sent you a PM.

Cheers,
Danny