.NET Agent version 9.1.04

Elite SysAider
Thank you so much!

I have the upd_x86.zip and upd_x64.zip files save to my sysaid downloads folder.

One question, looking in my tomcat HTTP logs, I still see attempts to download update.zip and upd.zip - what is it that is downloading these files?

SysAid VP Customer Success
Hi BAustin,
I don't believe using an MST file created with older version should cause such problem, but just for the sake of testing, can you try creating a new MST file and deploy the agent with that?

I'm stilll having issues with these new MSI files (as posted in here: https://www.sysaid.com/Sysforums/posts/list/15/10080.page). I've downloaded the updated ones on this page and tried to deploy it but getting the same result. I have even used a basic Window 7 build with .NET installed and nothing else. I have even removed the anti-virus.

I get this event log on some of the machines.

Event Log: 1035
Windows Installer reconfigured the product. Product Name: SysAidAgent. Product Version: 9.1.04. Product Language: 1033. Manufacturer: SysAid Ltd.. Reconfiguration success or error status: 0.
I'm having problems during upgrade of sysaid on computers with windows XP.
I tried to install the 9.1.04 but the problem still exist.
the error (in the pic attached) come out at the startup of the computer, and when I try to open the sysaid agent.
the F11 shortcut doesn't work, and there's no shortcut icon on the desktop, so I've to go in c:\program files\sysaid and manually open the SysAidSessionUtilities.exe, but it still doesn't work.
someone can help me???
I've this problem on a big group of computers.
thank you!!!
Super SysAider
Hi MarcellaITCare,

I am not sure exactly what the error message says, however I believe this may be due to the XP machine not having the necessary .NET framework installed.

Please also verify if the machines are on Service Pack 3 or not, as there have been similar issues with error messages referring to endpoints not being found in DLL's, which are due to the XP machines only being SP2.

Please let us know if you resolve the issue, otherwise, please submit a Service Request to Customer Relations by sending an email to support@sysaid.com.

Thank you.
Problem Solved!!!
It was the SP3 missing!!!!
.net was correct.... =)
It appears in our case that the transform is not being applied to the 64 bit msi file.

The client installs without a configuration. I'm trying to figure this out but its a bit strange. x64 agent install on windows 7 x64 clients via group policy.
Yes it's strange. I've sat down at several computers running a batch file to initiate the agent install process. It pretends to do an install but never finishes. Mixed experiences on very similar win7 computers.
Maybe a new release will fix this.
I'm now attempting to use a standalone transformed MSI integrated package. I 'll let you know how it all works out in an hour or so.

Best Regards,


This message was edited 1 time. Last update was at Nov. 25, 2013 05:01 PM

Doesn't work. The MSI version is broken. After looking at this multiple ways, it appears to be packaged incorrectly and or missing dependencies. Part of the clue was when I transformed the file and the data1.cab file deleted itself. Sometimes you can't add cab files to a msi package as doing so breaks things. Its a better practice to just place the required files inside the msi wrapper.

Hopefully The devs are willing to fix this.

Best Regards,

Local install testing....

Installed .net 3.5 Doesn't install
Installed C++ redistr 2005, 2008, 2010....Doesn't install
Installed .net 4.0 doesn't install.

Turned off UAC.....guess what, it installs.

I 'm still working on figuring this out since the SysAid dev guys haven't.

This message was edited 1 time. Last update was at Nov. 26, 2013 08:58 PM

I'm regressing back and retesting.

I already know the data1.cab file is an issue, but I want to make certain that there are no other issues other than the UAC elevated application issue.
Updated Final Report:

*Data1.cab inside a MSI is a problem if you use orca to repack the msi file, attempting to do so will result in the data1.cab file being deleted and the package not being installed.

*With the default msi file being provided, during GPO deploy the transform file is being ignored. (We edited the msi file with installashield and manually edited the properties, bypassing that problem so that the package installs with the properties populated.) (verified via local install)

*Even being repackaged the properties values are being ignored. (when pushed out via GPO software deploy) The msi is being run without invoker rights. So the property values are being dropped.

*Entering this: PROXYSERVER (default value="none") into the transform file will also stop the new installer from installing. Use PROXYSERVER (default value="null") instead and it will complete. I verified that the old method works with the version 8.5 msi file.

All testing was performed locally, then retested via GPO software deployment to a clean test environment with UAC off.
The final test was a clean installation via GPO software deployment onto a windows 7 SP1 machine with UAC on.

Required actions by SysAid development:

The run as invoker property needs to be set while creating the MSI file. Here are some of the more common mistakes made: https://blogs.msdn.com/b/rflaming/archive/2006/10/01/uac-in-msi-notes-answers-to-questions-in-comments-from-earlier-blog-posts.aspx

Dump the contents of data1.cab into the msi. Do not use cab files inside msi's. It is a bad practice and in this case is causing issues.

Instruct users that default is: PROXYSERVER (default value="null") instead of PROXYSERVER (default value="none") when using the new installer.

This message was edited 6 times. Last update was at Nov. 26, 2013 09:57 PM

The agent test environment is awaiting. I responded to a sysaid support agent 30 seconds after receiving their e-mail and now I've sat for the last hour+ waiting for their response.

Very frustrating.

Evidently their support hours are 2AM-4:30PM EST.

So the agent was probably responding to his list of tickets for the day before heading out for the evening.

I'll try again in the morning.

This message was edited 1 time. Last update was at Nov. 26, 2013 10:15 PM

Here's my batch script code for finding the right OS version.
It might come in handy for others down the road when the MSI files are fixed.


START msiexec /i "S:\deploy\SysAidAgentx64.msi" /qb TRANSFORMS="S:\deploy\transform64.mst"

START msiexec /i "S:\deploy\SysAidAgentx86.msi" /qb TRANSFORMS="S:\deploy\transform86.mst"


This message was edited 1 time. Last update was at Nov. 26, 2013 11:32 PM