SysAid Notification Email Template

 
Author
Message
Elite SysAider
137
 
c71clark wrote:I'm having trouble with this. Here is the simple HTML used in the End User notification for the Body of the message. I am still testing, so hosting the pictures on the intertubes:

<table style="text-align: left; width: 551px;" border="1"
cellpadding="2" cellspacing="2">
<tbody>
<tr>
<td style="width: 170px;" colspan="3" rowspan="1"><img
style="width: 550px; height: 83px;" alt="MCIM Help Desk"
src="http://i.imgur.com/---.gif" align="middle"></td>
</tr>
<tr>
<td style="width: 170px;" colspan="3" rowspan="1">Dear
${ReqUser},
#if(${IsNewSr}==true)Your Service Request #${ID} has been recieved.
#else #if(${isClosedSR}==true) Your service ticket #${ID}, titled
#${Title}, has been closed.
#end</td>
</tr>
<tr>
<td style="width: 170px;">#if(${isClosedSR}==true
&& ${ReopenSR}!="0" )Click here if you would like to
reopen this service record: ${ReopenSR}
#end
</td>
<td style="width: 194px;"></td>
<td style="width: 170px;"></td>
</tr>
<tr>
<td style="width: 170px;"></td>
<td style="width: 194px;"></td>
<td style="width: 170px;"></td>
</tr>
<tr>
<td style="width: 170px;"></td>
<td style="width: 194px;"></td>
<td style="width: 170px;"></td>
</tr>
<tr>
<td style="width: 170px;"><img
style="width: 47px; height: 41px;" alt=""
src="http://i.imgur.com/---.jpg"></td>
<td style="width: 194px;"></td>
<td style="width: 170px; text-align: right;"><img
style="width: 62px; height: 37px;" alt=""
src="http://i.imgur.com/---.jpg"></td>
</tr>
</tbody>
</table>

When I get the email, it is completely blank, and the "source" is only:
<div dir="LTR"></div>

That's it. It's Outlook 2010.
Now, if I paste that same html into a custom signature and insert it into a message, all the html stuff, images, etc show up normally. Of course the filed codes do not resolve in this preview. If I send myself that message, the images and formatting are still there, but the codes still do not resolve and it is just a text dump of all the various statements.

Idea's?
it look like you messing in front of this src="http://i.imgur.com/---.jpg"></td> the < i thni it should be <src="http://i.imgur.com/---.jpg"></td> like this
SysAider
41
 
So I'm back at it after a time out. I have a functioning email template I am trying to polish up a little, but am having trouble getting Notes and the Resolution to show in the notifications.




When I put text into either of these places, it does not come out in the email. Basically, I want to show both Notes and a Resolution in a table, each in their own cell of a table.

Would it be accurate to read those to say: If the Notes field is there AND the field is not empty, display Notes.
?

This message was edited 2 times. Last update was at Aug. 25, 2016 01:46 PM

SysAider
27
 
Thank you for sharing, I was able to modify the enduser notification, and implement it. I use the admin notification but changed the top and bottom headers a bit. When I run my html in jsfiddle, it displays as I wan't it to, but when I copy it into SysAid, my Admin notifications are coming out blank. I'll attach what I have if there's anything obvious I'm missing, I would appreciate the the help.

Thanks!

csAdminTemplate-new1.txt

This message was edited 1 time. Last update was at Sep. 16, 2016 05:04 PM

SysAider
5
 
Try closing your #If on the same <td> .. for example, this is your code:
<td>  #if(${SubCategory}&& ${SubCategory}!="" )Sub Category:</td><td>${SubCategory}#end</td>

try this way:
<td>  #if(${SubCategory}&& ${SubCategory}!="" )Sub Category: #end</td><td>${SubCategory}</td>


jjimenez827 wrote:Thank you for sharing, I was able to modify the enduser notification, and implement it. I use the admin notification but changed the top and bottom headers a bit. When I run my html in jsfiddle, it displays as I wan't it to, but when I copy it into SysAid, my Admin notifications are coming out blank. I'll attach what I have if there's anything obvious I'm missing, I would appreciate the the help.

Thanks!

SysAider
4
 
Hi.

I am resurrecting this old post because I liked this template, and I am trying to get this template operational. I have the HTML working great in a browser, but I am also only getting a blank notification email when I paste the code into the End User Notification of SysAid.

I did check all my #if statements have a #end on them.

Any further ideas when using the code of this template, I know it is a number of years old, maybe this manner of HTML no longer works?

Here is my current code....
SysAider
7
 
Is there some way to prevent SysAid from trying to auto-format our Custom Notifications?

We're trying to make custom HTML notifications; line-breaks should be ignored in HTML but in our notifications, they're being converted to
tags.

Removing all the line breaks is a tedious extra step when trying to craft a new, custom notification!
SysAider
11
 
Hi
Does anybody know of a way to create new notifications that I can use to send different responses depending on the status of the SR or the users role/location etc. I can edit the existing 13 but cannot find how to add or create new.
Thanks
Elite SysAider
195
 
You can simply embed multiple IF conditions within the notification based on location/user group/company etc. If the conditions are too complex to manage, I suggest you to trigger the condition validation through after-save trigger.