Some text via email turning into symbols

 
Author
Message
SysAider
18
 
Will do but it looks like the Support team will need to fix this for us, so another weekend down might be in play. I tried changing the collation type at the DB level as the default, but it looks like it was changed at an item level. So on every column, index, key, etc...has to be changed and I actually tried to. But some couldn't be changed because they were tied to other columns/indexes. Frustrating and annoying.
SysAid Community Manager Product Team
4866
 
Yes, this is what I was referring to, please open a ticket with support on this
SysAider
18
 
Ok Guys, this is going to be a long message, but well worth it, trust me. So I've noticed this weird text turning into symbols issue only with quotes and double quotes ( ' and " ). It would change them respectfully to ‘ and “ . Very annoying, but I finally got with someone this morning who fixed my issue and I made sure to understand what he did fully so I can share here.

I also want to say this had nothing to do with the SQL Collation type.

Before you start, please make sure you have a backup of your config files and database.

First thing you need to do is remote into your SysAid server, mine is a windows box. Navigate to C:\Program Files\SysAidServer\root\FILESYSTEM\AccountName\accountConf . Once in here sort by Date Modified, you want to find the newest accountConf file and edit with Notepad. Search for the tag "<emailIntegrationRemoveEmoji>" without the quotes. Mine was set to True and we changed it to False like seen below. Save this file with it's current name and location.

Old
<emailIntegrationRemoveEmoji>true</emailIntegrationRemoveEmoji>

New
<emailIntegrationRemoveEmoji>false</emailIntegrationRemoveEmoji>

Next we went into Services and stopped the "SysAid Server" service. We needed this stopped in order to run the next command. Open Command Prompt (Run As Administrator) and put in the below commands on separate lines pressing the Enter key after each:

cd "C:\Program Files\SysAidServer\util"

ReproduceAccountConf.exe MostRecentAccountConfFileName.xml AccountName

You will see some logs show up like below:

log4j:WARN No appenders could be found for logger (com.ilient).
log4j:WARN Please initialize the log4j system properly.
log4j:WARN See http://logging.apache.org/log4j/1.2/faq.html#noconfig for more info.
.... Loading account AccountName
.... Reproduce configuration for account: AccountName ended successfully.

Go back to Services and start your "SysAid Server" service, wait about 5 minutes and send in a test email. This process resolved our issue that we have been having since January.

This message was edited 1 time. Last update was at Jun. 11, 2018 11:00 AM