Problem with Thai Characters

 
Author
Message
SysAider
2
 
Hi mshi,

I have read your reply that you had been experienced the same issue with you in Chinese language environment. And it was already fixed.

Please teach me how to set it up in Ubuntu?

I have installed Sysaid Pro 7.5 version in Linux Ubuntu server environment which has mysql database.

And I found that on sysaid interface the chinese show "?" on the textbox field after save/ submit the service request.

I have added the two lines that you provided as below in mysql/my.cnf:

character_set_server=utf8
character_set_client=utf8

The problem still exist.

Please reply me asap

Thanks.


SysAider
37
 
Hi, wf_gold

Please install SysAid on Ubuntu with correct utf8 configuration as the following steps:

Step 1, Install Ubuntu and MySQL

Step 2, Install java
sudo apt-get install sun-java6-jdk

Step 3, Install Tomcat and configure for it

sudo apt-get install tomcat6

edit the file of /etc/init.d/tomcat6
search the line of #use java security manager? (yes/no), then replace the the following line of
TOMCAT6_SECURITY=yes
with
TOMCAT6_SECURITY=no

edit the file of /var/lib/tomcat6/conf/server.xml then
insert the following item in < connector />
URIEncoding="utf-8"

restart Tomcat
sudo /etc/init.d/tomcat6 restart

Step 4, Modify the configuration for MySQL
edit the file of /etc/mysql/my.cnf
insert the following two items in [mysqld]
character_set_server=utf8
character_set_client=utf8

Step 5, Install SysAid

Hope you have good luck.

Mshi

This message was edited 1 time. Last update was at Jan. 12, 2011 10:20 AM

SysAider
2
 
Hi Mshi,

Thank you for replying.

However, after I followed the steps to setup UTF8 encoding in Tomcat,

The sysaid still cannot show the chinese characters after apply the service request.

Please see the attachment.
SysAider
37
 
Hi, wf_gold

I don't have other idea for your issue.

Please submit a service request to hlepdesk@sysaid.com.

I always got satisfied anwsers from SysAid Support Team.

Best Regards,

Mshi
SysAider
36
 
Sawasdee krub Khun Mshi, (Thai traditional greeting)

Thank you very much for your clear instructions posted on 12/01/2011 22:15:56.

After facing with this issues since SysAid 6.5.05, I had Thai characters works on SysAid 7.5.05.

The browser must be set to use Unicode(UTF- UTF-8 encoding then everything displayed correctly in Thai as you may see in the file attached no more ???? ???? ????.

My SysAid run on Ubuntu Server 10.04.02-LTS using dual Opteron server with 8GB RAM.

The only issue I have now is "PermGen space" from Java and 100% CPU load...which I ended up restart tomcat6 process more than 10 times today as it appeared frequently as many users started to use the SysAid 7.5.05.

I searched from SysAid Forum and found:

export CATALINA_OPTS="-Xms1024m -Xmx2048m -XXermSize=128m -XX:MaxPermSize=256m -XX:+CMSClassUnloadingEnabled"

PermSize=128m

Let's wait and see if this will be the magic pills for the Java error and 100% CPU load.

(^_^)
Songkrant

P.S. Whoelse in Thailand using SysAid...I am going to set more Thai language on SysAid.

This message was edited 4 times. Last update was at Feb. 03, 2011 01:31 PM

SysAider
36
 
For more than a week, I have had SysAid 7.5.05 on Ubuntu Server 10.04.02-LTS with no more errors from Java "PermGen space" and 100% CPU load.

So I confirmed that:

export CATALINA_OPTS="-Xms1024m -Xmx2048m -XXermSize=128m -XX:MaxPermSize=256m -XX:+CMSClassUnloadingEnabled"


Please note on option PermSize=128m, this web page translate : P as one emoticon so please correct this carefully.

Thanks again to mshi for your handy note for SysAid installation on Ubuntu Linux.

(^_^)
Songkrant

This message was edited 2 times. Last update was at Feb. 11, 2011 09:19 PM