Using SysAid with gmail.....

 
Author
Message
SysAider
2
 

Hi,

I found a solution to integrate SysAid with gmail.com.

Gmail requires the use of SSL for email, and this is not supported by SysAid.

Using Stunnel it is possible to do this.


https://www.stunnel.org/

with the configuration proposed by SpamPal for windows in ths article:


https://spampal.sanesecurity.com/manual_eng/servers/stunnel/stunnel.htm

and i can send and receive mails to and from a gmail.com account.
The stunnel the configuration is:

c:\stunnel\stunnel.conf { then configuration file }

cert = stunnel.pem
socket = l:TCP_NODELAY=1
socket = r:TCP_NODELAY=1

client = yes
debug = 7
output = stunnel.log

[pop3s]
accept = 127.0.0.1:995
connect = pop.gmail.com:995
[ssmtp]
accept = 127.0.0.1:465
connect = smtp.gmail.com:465


In the Preferences/Integration/Email section of your SysAid:

Outgoing emails

SMTP host name :127.0.0.1
SMTP port :259
Email address :myaccount@gmail.com
User (optional for authentication) :myaccount@gmail.com
Password (optional for authentication) :mypassword
Encoding : utf-8
Content type :text/plain; charset=utf-8

Incoming emails

"Checked" Enable incoming email integration.
"Checked" Enable SSL Secure

Warning! Do not use your own email address. Inputting your own email address will disable it.
Please input an email account created especially for the email integration.

Protocol : POP3

Mail Server :pop.gmail.com Email address :myaccount@gmail.com

User :myaccount@gmail.com Password :mypassword

This is enough to send and receive emails.

You can change the ip adress for a server like 192.168.0.100 ande send the mails true this server.

This solution works with any software that is needed to send mails through gmail

I hope this can help.

ijfarias@gmail.com
Ignacio Farías Díaz


This message was edited 1 time. Last update was at Mar. 18, 2009 10:48 AM

ijfarias@gmail.com
Ing. Ignacio Farías Díaz
SysAid Wiz
2449
 
Hello ifarias.
Thank you for your guide, but i think this post should not be in the feature request forum, so i'm moving it to the FAQ forums so it can be found easily.

Best regards.
Haim
Pushing IT forward
SysAider
2
 
I forget something

# Configure your client to match the settings below:
Incoming Mail (POP3) Server - requires SSL: pop.gmail.com
Use SSL: Yes
Port: 995
Outgoing Mail (SMTP) Server - requires TLS: smtp.gmail.com (use authentication)
Use Authentication: Yes
Use STARTTLS: Yes (some clients call this SSL)
Port: 465 or 587
Account Name: your full email address (including @gmail.com or @your_domain.com)
Email Address: your email address (username@gmail.com or username@your_domain.com)
Password: your Gmail password

or follow the link: https://mail.google.com/support/bin/answer.py?answer=13287
ijfarias@gmail.com
Ing. Ignacio Farías Díaz
SysAider
1
 

Ignacio,
I try your solution, but for me: not run.
SysAid can receive emails (before your solution too), but can't send messages.

We have google apps account: helpdesk@mydomain.com.ar

just some questions:
- Why port 259?
- Is neccesary a mail client in my server?

Can you help me?

Kind regards,
Mario.
thorpett@gmail.com



SysAid VP Customer Relations
604
 
UPDATE:

SysAid release 6.5 now supports SSL for both SMTP and POP3/IMAP. This means that gmail is fully supported for email integration.



Joseph.
SysAid Customer Relations
1092
 
Hi guys,

As you all know since v6.5 SysAid support email integration with Gmail accounts and in some cases it requires TLS connection and not SSL and in this case you will need to contact our support team

Before you do, please try to enable the SSL check box and replace the port number to 587.

Let me know if this helps you guys.

Looking forward to hearing from you.

This message was edited 2 times. Last update was at Dec. 13, 2010 04:47 AM

Best Regards,
Itay
SysAider
3
 
Hi all,

I am unable to get integration fully functional. The gmail setting were enter correctly. System are able to receive email. but unable to send any email.
SysAid Customer Relations
1092
 
Hi LoCoLyRiC,

Welcome to our community.

This can happen either because the SMTP settings are incorrect or the notification regarding SR's were customized incorrectly.
Please make sure you set the following under Preferences> Integration > Email > Modify:
SMTP : smtp.gmail.com
SSL : should be checked
User : YourEmailAddress (AAA@gmail.com)
Password : this mailbox password.

If It's still doesn't work, please go to Customize > Notification > click on "Return All to Default".

Please update me on your progress.

Looking forward to hearing from you.
Best Regards,
Itay
SysAider
7
 
I'm having the same problem. Incoming mail works fine but outgoing is a no go. I've tried everything I can think of at this point. Error log below. My SMTP settings say to use TLS encryption, not SSL. I've tried with and without the SSL as well. Tried using the POP and/or IMAP ports and configuration and can't get anywhere. This is the final piece needed for us to get going with this system....

2012-08-24 16:34:01,116 [Thread-766] ERROR com.sysaid - Exception while sending email, message:Could not connect to SMTP host: pod51011.outlook.com, port: 587
javax.mail.MessagingException: Could not connect to SMTP host: pod51011.outlook.com, port: 587;
nested exception is:
javax.net.ssl.SSLException: Unrecognized SSL message, plaintext connection?
at com.sun.mail.smtp.SMTPTransport.openServer(SMTPTransport.java:1934)
at com.sun.mail.smtp.SMTPTransport.protocolConnect(SMTPTransport.java:63
at javax.mail.Service.connect(Service.java:295)
at com.sysaid.server.bl.run(Unknown Source)
at java.lang.Thread.run(Thread.java:619)
Caused by: javax.net.ssl.SSLException: Unrecognized SSL message, plaintext connection?
at com.sun.net.ssl.internal.ssl.InputRecord.handleUnknownRecord(InputRecord.java:523)
at com.sun.net.ssl.internal.ssl.InputRecord.read(InputRecord.java:355)
at com.sun.net.ssl.internal.ssl.SSLSocketImpl.readRecord(SSLSocketImpl.java:789)
at com.sun.net.ssl.internal.ssl.SSLSocketImpl.performInitialHandshake(SSLSocketImpl.java:1112)
at com.sun.net.ssl.internal.ssl.SSLSocketImpl.startHandshake(SSLSocketImpl.java:1139)
at com.sun.net.ssl.internal.ssl.SSLSocketImpl.startHandshake(SSLSocketImpl.java:1123)
at com.sun.mail.util.SocketFetcher.configureSSLSocket(SocketFetcher.java:507)
at com.sun.mail.util.SocketFetcher.getSocket(SocketFetcher.java:23
at com.sun.mail.smtp.SMTPTransport.openServer(SMTPTransport.java:1900)
... 4 more

SysAider
7
 
Hi all,
I have the same problem and the same error message.
Gmail with no ability to send email, you have any idea of what email provider to use?
Thanks,
Laura

This message was edited 1 time. Last update was at Nov. 09, 2015 10:38 AM