Can't login to Free Cloud account

I have setup a free cloud account and was sent the login details which allowed me to login fine. No more than 3hrs later i have tried to login again and it won't accept the credentials, even though i haven't changed anything. I tried to reset the password but it tells me it doesn't recognise the username/email address of the account i am trying to reset. Any ideas? SysAid support bluntly refusing to help as I'm not a paying customer. I might be a paying customer in the future but if i can't even logon to use the product then they are never going to win my business.
SysAid Product Manager Community Manager
Hi Steve,

I've sent you a private message with login information.

I am facing same issue.

Created new free cloud account and unable to login first time with sysaid provided credentials.

Sysaid support denied to help me by providing correct credential for the first time which is the basic and initial need of any customer both free or paid. They show us a funny reason that we will not get help from them as we are not a paid customer.

Can anybody help me on this? We are not able to login not a single time since we created that free account. I created it not more than 24 hours before.

Pratip Ghosh

I have same issue. Got credentials copy&paste and have:
Incorrect account ID.
Letters must be typed in the correct case.
Please make sure the Caps Lock key is disabled.
I am facing same issue too. I cant login at all. Even self-help for password reset doesn't work too.