Templates do not load when tickets are e-mailed

 
Author
Message
Elite SysAider
220
 
Hi,

When a user submits a ticket trough the e-mail and is imported - and we choose a catagory after it does not load that template that is behind that catagory. It works fine if we submit a ticket trough the admin portal. We only use the catagory field in the default template btw.

Also the e-mailed ticket which have a standard catagory (N/A) does not appear in the incident section on a static filter. We made a static filter that is called "problem_type != 'AX-incident' but it also filters out the N/A what can I use so that it will show the N/A tickets as well?


Thanks
SysAid Wiz
318
 
Hi Spikeycloud,
have you tried to set "sub-type" in Action Builder for that Email Rule?
It's not like applying a Template if you need to set specific values in field, but it can be enough to show required fields.
Hope it can help.

For the second issue you shoul take a look at the logs to better understand what happens and share some screenshot.
Cheers.
Elite SysAider
220
 
Tomaso wrote:Hi Spikeycloud,
have you tried to set "sub-type" in Action Builder for that Email Rule?
It's not like applying a Template if you need to set specific values in field, but it can be enough to show required fields.
Hope it can help.

For the second issue you shoul take a look at the logs to better understand what happens and share some screenshot.
Cheers.


Hi Tomaso,

This does not work. We can change it if we add the sub type field in the e-mailed ticket and change that - but trough selecting a catagory it still does not change. We would really like to do this trough the catagory because it also works this way in the end user portal and the admin portal - and everything is filtered and configured based on categories. So it is kinda surprising that it work everywhere expect when the ticket is e-mailed.

BTW we want that most users submit trough the portal because we configured everything in there (special templates, user rights etc) but there will be always users that don't listen and keep submitting trough the e-mail.

This message was edited 3 times. Last update was at Jan. 09, 2018 04:40 AM

SysAid Community Manager Product Team
4866
 
Hi Spikeycloud,

This sounds pretty strange. Could you please open a ticket on this with our support team for further investigation, and update here once a solution is found?

Thanks,
Danny

This message was edited 1 time. Last update was at Jan. 09, 2018 09:54 AM

Elite SysAider
220
 
Danny Tashiev wrote:Hi Spikeycloud,

This sound pretty strange. Could you please open a ticket on this with our support team for further investigation, and update here once a solution is found?

Thanks,
Danny


Sure no problem.
SysAider
1
 
Hi Spikey,

Any feedback on a resolution for this issue?

Thanks
Elite SysAider
220
 
SuperHaas wrote:Hi Spikey,

Any feedback on a resolution for this issue?

Thanks


No not a resolution, it seems once an e-mail is submitted you can only change the template with changing the sub-type. This was intentional. Not sure anymore why it is intentional. Maybe someone of the staff can shed a light on this?

Edit:

Searched my old e-mails and found the explanation. Can't find the ticket anymore in the Sysaid helpdesk though.

Hi ,

I am very sorry for the late response,
The behavior you're describing is by design.

Templates (for incidents anyway) are only used when the ticket is created and not once there is already a ticket number.

The reason is that templates contain default data, such as instructions inside the description field. If you 'load' a template into an existing SR, you would overwrite existing data with the template data. This is against the design and surely something that no one wants.

You can always change the sub-type of any existing ticket to change the form layout. But you can't reapply a template for an incident after it is created.

You can change the template of a request/change/problem but you get a popup saying it will overwrite all the action items and workflow tabs, for the same reason.

Please let me know if this answers your question.

Best Regards,

This message was edited 1 time. Last update was at Apr. 11, 2018 06:46 AM