Loading CI's from a Spreadsheet - failing


I have a demo cloud instance of SYSAID and I am testing and configuring this system for us to make use of CI's.

I am trying to load CI's from a CSV file and the results are inconsistent. It seems very hit and miss if the file loads at all, and if it does load, not all rows are imported.

If I try and load the full file (204 rows) I just get an error message 'Internal error' appear in red.

I have gradually reduced down the number of rows in the file, until I can get a file to load. I now have a file of 29 rows, and it will load 24 of them. I have worked out which 5 rows are not loading, but cannot see anything untoward in the data as to why they do not load. (Also, this file sometimes fails to load with the same 'internal error' message).

I have also changed all of the fields (apart from the key field) to not be mandatory, to try and help it through. The key field is unique so that is not the issue.

Settings are as follows:
Do not import header
Delimiter is ","
Number of fields 31
Key field number 4

Are there any log files anywhere I can look at to work out (a) why some rows won't load, and (b) why I get an 'internal error' when I try to load the full file?

Failing that are there any other reasons I can look at to try to understand why some of the data wont load?

As an update to this, after multiple attempts I have now got the full file to import (without changing anything). However it only imports 164 of the 204 rows, and I can't see any reason why the 40 rows won't load.

It seems if I keep trying to upload the same file, I still get the 'Internal error' message, but every 4th or 5th attempt it will import and process the file (albeit only 164 rows).

It would be really useful if there were error logs somewhere, to try to understand what the data (and sometimes the file) is being rejected.