New specific permission for deleting assets- FR#29377 - 19.3.10

 
Author
Message
SysAid Product Manager Community Manager
5276
 
SysAid’s new Purge Inventory permission allows admins to exert more granular control on the permissions relevant to Asset Management in their company.

Let’s say Jon is the CFO for a large, international company. He may want to ensure that sysadmins in the London branch can’t delete assets that are located in the New York branch and visa versa. This permission allows him to specify which admins can delete which assets, giving him a bit more control over his IT environment.



For more information about permissions , please see our online help.
SysAider
27
 
We can't delete assets at this moment, error message:
There are some assets that were not deleted due to permissions limitation.

We're still on v19.2.22 b11, so this permission is not active.

Hopefully this will be solved with 19.3.10,

Regards, Philip
SysAid Product Manager Community Manager
5276
 
Hi Philip,

We are unable to reproduce the issue on this version on our side, could you please contact our support team for further investigation? PM me the ticket number once you get it.

Thanks,
Danny
SysAider
4
 
I am having the exact same issue as Phillip. On version 19.2.30 b20
SysAider
27
 
Our problem seems to be solved, spontaneously . I can delete assets now. We are on version v19.3.30 b48.
Regards Philip
SysAider
9
 
I just downloaded the latest x86 on-prem solution and it's v19.2.32 b4. I have the same problem except the menu to purge isn't even there. see attached picture. How do I get 19.3?
SysAider
12
 
I just downloaded the latest release (19.2), and I'm getting the same error.

"There are some assets that were not deleted due to permissions limitation" even though I'm a full Sysaid admin.
SysAid Product Manager Community Manager
5276
 
Hi, if anyone is encountering this issue, please contact our support team for an in-depth investigation, and PM me the SR# you receive.

Thanks,
Danny
SysAider
12
 
Here's the response I got back from support. I can confirm that it works:


Thank you for contacting SysAid Customer Support team.

Please be informed that we have bug raised for this behavior and it has been fixed on the upcoming versions of the product. The bug number is: 35814 and the version with the fix is: 19.3.10.

There is a workaround for this issue, you will need to have the asset group changed from the current one to '\' and in this way it should allow you to have them deleted.

If will you experience any issues, please don't hesitate to contact us back.

Really sorry for the inconveniences created. I wish you a great day ahead.

Elite SysAider
105
 
Hello!

I am having just the same issue. Currently we are using version 19.2.30.

How do I get version 19.3.10?? As far as I know ver. 19.2.30 is the latest, isn't it??

Look forward to your help.
SysAid Product Manager Community Manager
5276
 
Hi simental,

This is indeed the latest On-Premise version. This fix will be implemented in the next On-Premise - at the moment the workaround mentioned here can be used.

Cheers,
Danny