Unable to install the agent on some workstations - Solution found

 
Author
Message
Elite SysAider
121
 
I have this incident open with tech support but thought I might save them the trouble if somebody else has seen that and found a way to fix it.

I have a four workstations (for about 500 workstations) that gives me the error :

"Could not load SSL Library"

when I try to install the SysAid Agent on it. The error (popup window) appears right after I click on 'Next' at the 'Account Information' wizard screen. When I click on the popup Ok button, the installation ends.

All the workstations are running Windows XP SP3.

Nothing gets reported in the event log, nothing is written in c:\temp, c:\tmp, c:\documents and settings\{user}\local settings\temp. The c:\program files\sysaid directory does not get created either but a few entries (not all of them) get created in the registry HKLM\Software\Ilient key.

I'm running SysAid V6.5.08. I tried to disable the Windows built-in firewall as well as the anti-virus program to no avail.

Edit: Forgot to add, the clients talk to the server on port 443 (https).

Anybody saw this before?

Thanks.

This message was edited 2 times. Last update was at Jun. 25, 2010 02:18 PM

SysAider
1
 
We would like to know which exact file you have tried to run in order to deploy the agent to those Windows XP workstations .(by the web application/ deployment tool/ locally ?)
Eyal cohen
SysAid Supprt
Elite SysAider
121
 
I ran directly SysAidAgent.exe on the workstation. The file is stored on the network and it was successfully installed on all the other workstations. I normally run it silently using the following command :

SysAidAgent.exe /VerySilent /URL https://{serverURL) /account {accountName} /serial {serialID} /AllowRegister Y /AllowRemoteControl Y /SubmitSRShortcut "Centre d'assistance technologique" /HotKey 122 /ConfirmRC Y /RandomMachineID N /AllowSubmitSR N

but even if I simply run the installer and supply the fields manually, I get the same error.

Elite SysAider
121
 
Found the solution. I'll post it here in case somebody else encounters the same error :

The SSL files (libeay32.dll and ssleay32.dll) that were is c:\windows\system32 were too old and missing some exported functions that the SysAid agent installer needed (hence the unable to load the SSL library). I renamed the two files and the SysAid agent installer proceeded at installing the agent successfully. It also copied its own, newer version of the two files into c:\windows\system32.

The agent itself do NOT load those two files though, it loads them from its own installation directory (c:\program files\sysaid). It's just the installer that wants to do that. I kept the newer files in c:\windows\system32 otherwise I believe an update to the client would fail as well.

I asked tech support to have the installer look in its own temporary installation directory first (where the newer files are found) to avoid this error in the future.

This message was edited 1 time. Last update was at Jun. 25, 2010 10:12 AM

SysAider
47
 
Thank You I had the same problem on a server and your solution worked.
Super SysAider
87
 
This seems to still be an issue in release 8.1.03. We were running into the same issue and this has worked for us as well.