user company displays "none" in the end user portal

 
Author
Message
SysAider
37
 
In case this question has been answered already in the manual or the forum then I would like to apologise; I have been unable to find it. I think I am doing it correct but the result is not as hoped. I am a new user to SysAid (started last week).

This is what I have done:
A new end user has been created: preferences -> user management -> end user management -> new user
A new company has been created: preferences -> user management -> companies -> new company

In the preferences -> user management -> end user management -> new user -> general details the company has been added using the 'Company' dropdown list.

However; when that user logs in the end user portal and goes to 'Submit a Service Request' the value shown by company displays "None" and the same goes for the department.

So the Company and Department are visible for the end user but there is no value displayed. What am I doing wrong?

Thanks in advance.


Edit: typos

This message was edited 1 time. Last update was at Feb. 02, 2011 07:52 AM

SysAid Customer Success Manager
760
 
Dear HostVentura,

I have recreated this on my environment and indeed the same is happening here also. I am forwarding this to our Research and Development team and we will notify you on their findings.

We will be glad to further assist you any time.

Thanks Inna
SysAider
37
 
Hi Inna,

thanks for having a go and even more thanks for taking away my doubts about how to handle this. I will await response.
SysAid Customer Success Manager
36
 
Hi Ingmar Oost,

You will need to use HTML customization in order to resolve this issue.
In case you are not familiar with HTML customization, please follow these steps:

1. Go to ...\SysAidServer\root\WEB-INF\conf\html.

2. Copy the submit-service-request.htm file to a new html folder (eg. c:\custom_html).

3. Edit the html files in the new location, add the following line to the file:
$frm.printControl('request_user',false,false,$loginBean.getUserName())

4. Go to Customize > Appearance
a) In the HTML Files Location field, enter the full path to the new html folder.
b) Click on Save.
c) Click on Reload Templates to update the changes you made in the html files.

5. Open the relevant pages to verify that your newly designed End User Portal and Login page are displayed.