user filter in ldap integration

 
Author
Message
SysAider
4
 
Hello,

I'm trying to set up ldap filter for users in ldap intergation. I have 300 users in AD domain but i want only 80 of them to use SysAid
I've set up a special group SysAid for those users.
My user filter (&(sAMAccountName={1})(memberOf=CN=SysAid,OU=SysAid,DC=domain,DC=local)(mail=*))

but if i'm trying to update users from ldap - i'm recieving all 300 users insead of 80...

what's wrong?
Thank you



Super SysAider
72
 
Try the query: (&(sAMAccountName={1})(memberOf=*SysAid*)(mail=*))
SysAider
4
 
no difference, all 300 users in sysaid.

but if i use ldapsearch with the same filter - the result is 80 users...
Super SysAider
72
 
Did you delete all 300 users from the database BEFORE re-running the ldap import?
SysAid Wiz
2449
 
Hello kert,
Where exactly did you placed the filter? you should put the filter under "user class filters"
The correct syntax for the filter should be:

(&(sAMAccountName=user)(memberOf=CN=SysAid,OU=SysAid,DC=domain,DC=local)

Also, can you please tell us why did you added the "(mail=*)" syntax? as the syntax dows not add anything to the filter.

Please try the above filter, and then delete all end users from your users list and then refresh the user list from LDAP and tell us if this is working.

Best regards.
Haim
Pushing IT forward
SysAider
4
 
Hello, Haim

I've put (mail=*) to exclude users who doesn't have an email address

Now my ldap config is:

user class filter: (&(sAMAccountName=user)(memberOf=CN=SysAid,OU=SysAid,DC=domain,DC=local))
user filter: sAMAccountName={1}

I also tried without user filter...

And when I delete all end users from database and refresh users from ldap - SysAid says "No users found"
Super SysAider
72
 
The user class filter should be (&(objectCategory=user)(memberOf=CN=SysAid,OU=SysAid,DC=domain,DC=local))

This of course assumes that the group's common name is SysAid, in the OU called SysAid off the domain root.
SysAid Wiz
2449
 
kert wrote:Hello, Haim

I've put (mail=*) to exclude users who doesn't have an email address

Now my ldap config is:

user class filter: (&(sAMAccountName=user)(memberOf=CN=SysAid,OU=SysAid,DC=domain,DC=local))
user filter: sAMAccountName={1}

I also tried without user filter...

And when I delete all end users from database and refresh users from ldap - SysAid says "No users found"


Please open this case as a service request on our helpdesk by sending an email to helpdesk@sysaid.com with sending screenshots of your LDAP configurations (the entire screen) and a copy of the SysAid log folder (zipped) for our review.

This information will assist us in resolving this issue on the best possible way.

best regards.
Haim
Pushing IT forward
SysAider
4
 
i've solved this problem by setting up these values:

user class filter: (&(objectCategory=user)(memberOf=CN=SysAid,OU=SysAid,DC=domain,DC=local)(mail=*))
user filter: sAMAccountName={1}

now it's working.
thanks for your attention
SysAider
25
 
Hi guys - we want to do this too, but as a newbie, I've no idea where to enter this information. Can anyone give me a quick step-by-step?

Thanks.
WeZ
Super SysAider
55
 
go to your integration section under your helpdesk settings. . . if you're still lost, check the documentation for your release . . .
Elite SysAider
112
 
This is the same thing I am trying to do.

I understand the part about the filters, but I don't know what I need to enter for User root and group root. Also do I enter something in Group Class Filter?

Thanks.
SysAider
9
 
Thanks Hiam,

Your user class filter worked perfectly for me and solved the problem!

Regards
Paul