SysAid Upgrade Guide (for users running versions lower than 7.5)

 

Upgrade to the latest version of SysAid

 

Thank you for choosing to upgrade to the latest version of SysAid! In order to upgrade to the latest version, you must first upgrade to SysAid 7.5.

 

Once SysAid 7.5 is installed, if you are not running Derby database, you can upgrade directly to the latest version of SysAid. If you are running Derby database, you will first need to migrate your data to SysAid's new embedded database, MS SQL Express, as Derby is not supported in versions 14.1 and up. As a prerequisite to the database migration, you must upgrade from SysAid 7.5 to SysAid 9.1.02. At that point you can run the Migration tool provided in the upgrade installation package for versions 14.1 and up. Once you have successfully migrated your data, you can upgrade to the latest version of SysAid.

 

Upgrade to SysAid 7.5


  1. Download the appropriate version of the SysAid version 7.5 patch file to the computer which hosts the SysAid server. There are several versions of the patch file:
    1. Basic/Full Edition upgrade for Windows 32-bit
    2. Basic/Full Edition upgrade for Windows 64-bit
    3. Free Edition upgrade for Windows
    4. Basic/Full Edition upgrade for Linux
    5. Free Edition upgrade for Linux

    Make sure to remember where you save the downloaded file.

     

    Important: To upgrade to SysAid 7.5, you must have a valid support and maintenance account. You can check the status of your support account by attempting to log in to the SysAid Help Desk. If you find that your account has expired, please contact our support team.

 

  1. Run the downloaded patch file. If you are upgrading a Linux installation of SysAid, please go here for further instructions.
  2.  

  3. Click Next on the first screen. As suggested, you can close any unnecessary applications to improve performance of the installer.

  4.  

  5. Carefully read the license agreement. Click "I accept the agreement" and then click Next.


     

  6. Select the location of your SysAid server. The default installation location is already selected. Click Next.

  7.  

  8. Please wait while SysAid is upgraded to version 7.5. You will receive a confirmation message when the upgrade is complete. Click Finish to close the installer.
  9.  

    Description: C:\Users\david\AppData\Local\Temp\SNAGHTMLa51cc6.PNG

     

  10. If you have questions or issues at any time during installation, please contact our friendly support team at helpdesk@sysaid.com.

 

Congratulations! You've successfully upgraded to SysAid version 7.5.

 

What's next?

Now that you have upgraded to version 7.5, you can move on to the next step. As mentioned above, if you are not running Derby database you can upgrade directly to the latest version. Follow the instructions here to upgrade.

 

If you are running Derby database (which is not supported in versions 14.1 and up), you must migrate your data to SysAid's new embedded database, MS SQL Express. As a prerequisite for the data migration, you require SysAid 9.1.02. Follow the instructions here to upgrade to SysAid 9.1.02.

 

To check what type of database you are running:

 

  1. Navigate to Preferences > About.
  2. In the License Details section, see the Database Type row.