SysAid System Requirements for New Installations

 

Table of Contents

 

    SysAid server
    SysAid agent
    SysAid Remote Discovery Service (RDS)
    Integration
    User interface
    Patch Management

 

 

SysAid server

 

If you are using Patch Management, make sure to also consider the requirements in the Patch Management table.

 

Component Requirements
Minimum Recommended
Computer and processor 2.0GHz Quad-Core Xeon or equivalent
RAM 4 GB 8 GB
HD Space 16 GB 32 GB
Display resolution 1280x1024 display or above

Operating system

(x64)

  • Windows Server 2008 R2*
  • Linux/Unix**
Windows Server 2012 and above (Server 2016 and 2019 are supported)

Database***

  • MS SQL Server 2008 R2 Express****
  • MySQL 5.6 and 5.7
  • Oracle 10.4 and above*****
MS SQL Server 2019

 

 

* Windows 10, Windows 8, and Windows 7 SP1 can be used for test environments.

- .NET Framework 3.5 SP1 or higher is required.

 

**When the SysAid server is installed on a Linux server, manual agent deployments and RCG require the SysAid RDS (on a Windows machine).

SysAid supports the following OS versions:

- Centos - 7

- Debian - 9 stretch, buster 10

- Ubuntu - 16.04 Xenial Xerus, 18.04 Bionic Beaver, 19.10 Eoan Ermine, 20.04 Focal Fossa

 

*** For production environment it is recommended to use a separate machine for the database.

 

**** MS SQL Express requires an additional 1 GB of RAM, if running on the same machine, and can contain up to 10 GB of data (expected DB growth - dependant on number of assets and modules used, approx. 2-5 GBs per year).
***** Oracle is not supported by Linux installations.

 

Note: For optimal performance, we recommend using an RDS node and adding an additional node for every 2000 assets in your system. For more information, see the SysAid Remote Discovery Service Guide.

 

 

 

SysAid agent

 

Important: If your anti-virus solution maintains a white list of trusted paths, add the directory "\Program Files\SysAid" to the list. If it maintains a white list of trusted services, add the service "SysAidAgent" to the list.

 

Component Requirements
Computer and processor 1.5 GHz
RAM 512 MB
HD space 50 MB*
RAM usage 20 MB
Operating system (x64, x86)
  • Windows**: 10, 8, 7, Vista, Server 2019, 2016, 2012, 2008
  • Linux ***
  • Mac OS X 10.11 and above
  • Unix, IBM's AIX, FreeBSD, Solaris, HP-UX ****

 

* To enable Patch Management capabilities, an additional 1.5 GB is required

 

**.NET Framework 3.5 or above must be installed

 

*** For inventory feature only

 

**** Through a third-party tool. Please contact our support team for more information

 

 

 

 

SysAid RDS

 

If you are using Patch Management, make sure to also consider the requirements in the Patch Management table.

 

Component Requirements
Minimum Recommended
Computer and processor Dual-Core Quad-Core
RAM* 4 GB 8 GB
Network connectivity There must be a network connection available to the SysAid server
HD space 2 GB
Operating system (32-bit* or 64-bit)

Windows 10, Windows Server 2008, Windows Server 2008 R2, Windows Server 2012, Windows Server 2012 R2, Windows Server 2016, Windows Server 2019

* The amount of RAM determines the RDS's ability to manage a large number of agents and LDAP users.

**.NET Framework 3.5 or above must be installed.

*** The 32-bit installation of the RDS can be upgraded, but is not available for new installations.

 

Note: For optimal performance, we recommend that networks with 20 assets or more use RDS nodes. An individual RDS node should be used for up to 2000 assets. For more information, see the SysAid Remote Discovery Service Guide.

 

The RDS should be installed on a machine dedicated for SysAid.

 

 

Integration

 

Component Minimum Requirement
Email Outbound

SMTP/S

 

Email Inbound

Supported protocols:

  • POP3/S
  • IMAP/S
  • Microsoft Basic* (Microsoft Exchange and O365)
  • MAPI (Microsoft Exchange only, on local network only)
  • OAuth 2.0 (O365 and Google)
LDAP

Supported LDAPs:

  • Microsoft Active Directory (automatic configuration)
  • Any LDAP based directory, e.g. Open LDAP
API Requires an integrated development environment (IDE) that supports generating objects from a wsdl file
SMS
  • HTTP(S) account with a supported SMS gateway (Clickatell, Red Oxygen, Office Core/SMSCenter)
  • Support for any other gateway that supports HTTP(S) API can be added by Professional Services
SSO
  • Microsoft Active Directory
  • Central Authentication Services (CAS)
  • SSO Addons for credential providers that support the SSO process. See the SysAid Marketplace.
Exchange (Calendar) Supported with MAPI protocol for Microsoft Exchange only.
Office 365 (Calendar)

Supported with EWS protocol.

Report editing Requires iReport version 3.7.6

 

*Formerly known as EWS

 

 

User interface

 

Component Minimum Requirement
Supported browsers for admins Microsoft Edge, Chrome, Firefox, Safari*
Supported browsers for accessing the End-user Portal Microsoft Edge, Chrome, Firefox, Safari*
Supported browsers for accessing the Self-Service Portal Microsoft Edge, Chrome, Firefox, Safari*
Display resolution 1280x1024 display or above

Remote Control using RCG, My Desktop

Requires an HTML 5 compatible browser (Edge*, Firefox*, and Chrome*)

 

* Basic functionality has been tested.

 

 

Patch Management

 

If you are using the SysAid server and/or the RDS, make sure you also consider the requirements in the SysAid server requirements and the RDS requirements.

 

Important: If your anti-virus solution maintains a white list of trusted paths, add the directory "C:\ProgramData\GFI" to the list.

 

Example 1: Let's say you are using the SysAid server to manage 600 assets, and 300 of them are Patch Management enabled. Aside from the 2 GB of RAM and 4 GB of HD space required for the SysAid server, you also require an additional 4 GB of RAM and 10 GB of HD Space for Patch Management capabilities. In total, you would require 6 GB of RAM and 14 GB of HD space for the SysAid Server.

 

Example 2: Let's say you are using SysAid RDS in one of your branches to manage 200 assets, and 100 of them are Patch Management enabled. Aside from the required 2 GB of RAM and 400 MB of HD space required for the RDS, you will also need an additional 4 GB of RAM and 10 GB of HD Space for Patch Management capabilities. In total, you would require 6 GB of RAM and 10 GB + 400 MB of HD Spacefor the SysAid RDS.

 

Component Minimum Requirement
  1-100 Assets 100-500 Assets 500-1000 Assets
RAM 4 GB 4 GB 8 GB
HD space 5 GB 10 GB 20 GB

Internet Connection Bandwidth

1544 kbps 1544 kbps 1544 kbps

 

Note: A single SysAid RDS node (or SysAid server) can support up to 2000 Patch Management enabled assets. To enable Patch Management on more than 2000 assets, you must use additional RDS nodes.


If your RDS is using SysAid Patch Management, ensure port 1070 is opened for communication on the RDS for the target assets.


For other prerequisites for using Patch Management, see the Patch Management Guide.