Question

The "Add" tenant details button for MS Azure addon not working (is it possible to remove an addon so I can start setup from scratch again?)

  • 15 March 2023
  • 1 reply
  • 39 views

Badge

Hi

is it possible to remove an addon?

 

Back story:

We migrated to the cloud version of Sysaid and setup the MS Azure addon at the end of November 2022, it appeared to be working.

But sometime after that (starting around Dec 2022 or Jan 2023) it appears to have stopped syncing - we noticed new users setup in January weren’t being synced into Sysaid.  

If we clicked the “Test Connection” button, we received the error “azure connection error - failed to create web hook users for tenant XXXXXX.onmicrosoft.com. Error: Invalid notification url=’/addonsConsume/azure?type=users’

When I clicked on Import now, I recevied the same error (but it looks like it did sync the new users strangely enough)

 

While trying to troubleshoot the sync issue, I thought I’d delete the tenant details from teh Azure addon and readd them to see if that fixed it. I deleted the tenant details, but when I tried to readd them I found the “Add” button wasn’t adding them back in (it looks like a javascript syntax error occurs when you click the Add button).
Have tried multiple web browsers and different admin accounts, but still can’t add the tenant details back in. 

 

The MS Azure addon is now deactivated - and we can’t activate it until we add our tenant details (which we can’t do, see paragraph above) 

We had a filter for users, filtering on the company field.  It’s now showing “company = null” and I can’t seem to delete or fix this - it gives an error message “Please enable addon” when I try to edit the filter (but I can’t enable the addon - see the above paragraphs)

 

My next step is trying to delete the addon, and then start from scratch and set it up again - but I can’t see any way to remove the addon (maybe I’ve just overlooked something obvious?)

 

I have logged a support ticket, Incident #2398441, the last response I received was:
“By looking at the screenshots provided, you have not configured the Azure addon or it is missing the tenant details or it was deleted/removed.

From my perspective, what you have inputted in the Domain Name does not seem a domain name unless it is a custom one.

I would recommend on reading the below article and to finish set up the Azure integration:

https://documentation.sysaid.com/docs/azure?highlight=azu

Seeing that you don't even have Azure enabled, you need to enable it in order to make changes/updates.”

 

Which doesn’t seem very helpful.
Maybe I didn’t explain myself clearly when I submitted the job??


I’m kind of at a loss of what to do next (apart from setup an ldap agent on an on-prem server, but we want to avoid doing that, and anyway, that still leaves the broken MS Azure addon in our Sysaid)


1 reply

Userlevel 4
Badge +4

brendan:

I’m using on-prem but I don’t believe removing the plugin it’s going to do you a lot of good.

The borked setup would still be in the database and when you readd the plugin it would just pickup those old settings.

 

It seems to be that someone on tech support would have to clear that up for you.

I’d recommend reopening the ticket and rephrasing the ask.

 

Good Luck

John

 

Reply