iReport not opening? Java 8 may be the issue

  • 19 August 2015
  • 7 replies
  • 3709 views

Userlevel 2
Badge
  • Active talker
  • 53 replies
Hi All,

I ran in to this problem some time ago whereby for no apparent reason, when I ran iReport the splash screen would appear, but no loading took place, the usual progress bar made no progress.
I have since had a few support calls about this same issue, so I figure I will post the solution here.

The culprit is Java 8 as iReport is not compatible with Java 8 run time - well at least version 3.7.6 is not.
To resolve this issue, simply install the Java 7 JDK (unless already installed) on the machine on which iReport is installed and then configure iReport to use the JDK rather than your local JRE.

2 easy steps:
-----------------------
1. Download and install JDK7
(http://www.oracle.com/technetwork/java/javase/downloads/jdk7-downloads-1880260.html)

2. Modify the iReport config file 'ireport.conf' found in the 'etc' folder in the iReport installation directory.
(on a Windows instance; possibly: C:\Program Files\iReport-3.7.6\etc\)

Open the file in Notepad or equivalent plain text editor and find the line:
#jdkhome="/path/to/jdk"
Add a new line below it and replicate the property name (without the hash/"#") with the correct path to your new JDK install, Eg:
jdkhome="C:\Program Files\Java\jdk1.7.0_60"
*File paths are not necessarily correct for your system they are just for examples and are based on a Windows environment, please double check your install paths.

-------------------
Here is an unmodified ireport.conf for a 3.7.6 install in case anything goes wrong.
# ${HOME} will be replaced by user home directory according to platform
default_userdir="${HOME}/.${APPNAME}/3.7.6"
default_mac_userdir="${HOME}/Library/Application Support/${APPNAME}/3.7.6"

# options used by the launcher by default, can be overridden by explicit
# command line switches
default_options="--branding ireport -J-Xms256m -J-Xmx512m -J-Dorg.netbeans.ProxyClassLoader.level=1000"
# for development purposes you may wish to append: -J-Dnetbeans.logger.console=true -J-ea

# default location of JDK/JRE, can be overridden by using --jdkhome <dir> switch
#jdkhome="/path/to/jdk"

# clusters' paths separated by path.separator (semicolon on Windows, colon on Unices)
#extra_clusters=

7 replies

Great guide, Cael! Thanks a lot for sharing it here :)

Cheers,
Danny
This solution worked for me. Running on Windows 7 64 bit Dell.
Thank you so much for sharing the information. It has solved my problem
Hi...I am happy that the article worked for some of your guys...however as for me I am not sure I am following. I could not find the ireport.config even after searching for it in my entire Computer. I am running ireport directly from netbeans as it was installed through the ireport (1383067774_iReport-5.5.0-plugin) and I would like to be assisted on how I can configure my ireport in order for my reports to run from a jar file in a PC (windows machine) that does not have a Jasper Report Designer tool installed in it.

Again, you can also assist me on what the requirements are for me to run the reports from a jar are.

Thanks in advance
Thank you so much for sharing the information. I had the same issue under OSX and It has solved my problem !!!
Hi,
Even I am using iReport 3.7.0 and JDK 1.8. However I am able to create reports and execute them without any issues. To change the JDK version in iReport we need to open
X:\iReport-3.7.0\etc\ireport.conf and change the
=== jdkhome="C:\Program Files\Java\jdk1.8.0_191"====

It is worked fine for me.
Hi,

Reply