Question

iframe error

  • 20 October 2022
  • 5 replies
  • 54 views

Hello I tried insert page from SysAid in my webpage with iframe, but the server still lock the access. 

Someone now we fix this or who in SysAid we contact to update domain list to accept iframes?

 

 

<!DOCTYPE html>
<html lang="en">

<head>
<meta charset="UTF-8">
<frame-options policy="SAMEORIGIN" />
<title>Document</title>
</head>

<body>
<IFRAME src="https://globalbanking.sysaidit.com/servicePortal/submitSR?populateSR_id=17825&sspTargetUrlLink=0"
width=600 height=500 frameborder=1 scrolling=auto policy="deny">
</IFRAME>

</body>

</html>

 


5 replies

Userlevel 4
Badge

Hi @eluiz 

Double-check your browser is not limiting iFrame activity:

https://caniuse.com/?search=iframe

Let us know, 

Hi @eluiz 

Double-check your browser is not limiting iFrame activity:

https://caniuse.com/?search=iframe

Let us know, 

Its not my browser. X-frame policy com from the server with “sameorigin”. 
We don’t have access in the server. And SysAid doesn’t show how we register extra domain or change the policys.

 

Hi @eluiz 

Double-check your browser is not limiting iFrame activity:

https://caniuse.com/?search=iframe

Let us know, 

@Maayan Karstaedt do you know if SysAid IP Filter is a better solution to that problem?

https://documentation.sysaid.com/docs/sysaid-ip-filter?highlight=IP%20filteer
https://www.sysaid.com/it-service-management-software/marketplace/ip-filter

Userlevel 4
Badge

Hi @eluiz 

Not sure it will be relevant but worth testing out, let us know if you di and if it worked? 

Cheers,

 

Reply