Duplicate Assets from WMI & Agent

 
Author
Message
SysAider
15
 
We setup our SysAid environment to complete a WMI scan and add assets from it. And now we are starting to push out the SysAid agent to devices (via our software installation tool (Microsoft Intune)) -- we are now receiving duplicate entries for the same device. It shows both the WMI and Agent asset (see attached screenshot for the example of an Microsoft Surface device).

Won't SysAid see the duplicate device names and merge the two since they came from 2 different discovery types? Should we only use one method of discovery? Any recommendations would be appreciated before we push out the agent to all users.

Thanks!

Rob
IEDA CIO
SysAid Product Manager Community Manager
5260
 
Hi Rob,

Can you take a screenshot of the Asset ID field for one of the assets and its duplicate?

Thanks,
Danny
SysAider
15
 
Please see attached screenshot. NOTE: This is a single device -- see serial number.

This message was edited 3 times. Last update was at May. 31, 2016 11:22 AM

SysAid Product Manager Community Manager
5260
 
Hi Rob,

Does this issue occur only for one device, or for all of them? Normally, SysAid generates an Asset ID based on the hardware of the device, so if its hardware has changed between the WMI scan and the Agent deployment, it might be recognized as a different device, hence the duplication.
Another option could be the use of third-party software which is not officially supported by SysAid to deploy the agents.
The general route is to first deploy the agents to any relevant machines and then perform other scans if necessary, or selecting the assets you wish to deploy the agents to from the Asset List, and then clicking "Deploy Agent".

Let me know.

Cheers,
Danny
SysAider
15
 
We have only deployed the agent to a small handful of devices so far. A couple HP towers, which are not having an issue. But it is appearing specifically on our Microsoft Surface 3 devices -- as you notice WMI sees the device by it's BIOS manufacturer whereas the Agent sees it as Microsoft Corp. Not sure if this has anything to do with it as well. But very strange.

But just to clarify -- if something previously was discovered on a WMI scan, when an agent is deployed to it, the source will change for in the information and only a single record should appear, correct?

Thanks!
SysAid Product Manager Community Manager
5260
 
That is correct, but I'm not dismissing the possibility for a bug You have already sorted this, correct? Let me know if this issue recurs and we'll investigate it further.

Thanks,
Danny
SysAider
15
 
Danny -- I have no solution so far. Today we are beginning to deploy the agent to the rest of our fleet of devices, so I will be able to report back in the next day or two the results of any additional duplication. So far it appears to only be showing with Microsoft Surface devices.

-Rob
SysAid Product Manager Community Manager
5260
 
Alright, keep me updated!

Cheers,
Danny

This message was edited 1 time. Last update was at Jun. 01, 2016 10:32 AM

SysAider
15
 
We have not had 100% of agents deployed, yet but the trend continues for duplication of assets when WMI discovery is used following agent deployment. It appears this is happening only with Microsoft Surface 2 & 3 devices. The WMI is seeing/creating a different Asset ID and WMI is seeing the manufacturer as the BIOS manufacturer vs. the agent seeing the "true" manufacturer, in this case Microsoft, of the device. I will be PM'ing you a spreadsheet of the assets.
SysAid Product Manager Community Manager
5260
 
Thanks for letting me know. As already discussed by PM, I suggest opening a ticket with our customer support team to investigate this further.

I'd also like to ask any other SysAiders who encounter this issue to report here

Thanks,
Danny
SysAider
6
 
I have had the same issue.

What I did was to go in and manually removed the WMI scanned item and then edited the "Agent" scanned item to show the manufacturer as Microsoft Corporation.
Elite SysAider
110
 
We have this issue and will be looking into why and what can be done or should I say the best way to clean this up.

I may add that all the dups looks like they have been created by the agnet only

This message was edited 1 time. Last update was at Mar. 09, 2017 01:56 PM

SysAider
2
 
hi guys

cani aks how do you apsss the commands down to the msi with intune please I wast thinking

SysAidAgent.msi SERVERURL="oururl"
ACCOUNT="our ca id" SERIAL="s/n" CONFIRMRC="N" HOTKEY="F11" SUBMITSRSHORTCUT="F11 "