Looking to report on computer and windows service offline times

 
Author
Message
SysAider
3
 
I have been asked to provide a report showing when a windows 7 computer is off line and for how long.
I have also been asked to show when a Windows Process or Service running on a windows 7 computer was stopped or failed to start and for how long.

I seem to be able to get some Alerts to show in the Monitoring Event Log when a service or process is stopped. I can click on them and see a Daily graph.

Some stoppages seem to be missed or ignored by the system. It does not seem to be related to length of outage. Not sure what next steps to take to resolve.

I don't seem to be able to find reports that show the alert duration, outage duration, or monitored service or process times. All I can find so far is the Daily graph in the Monitoring Event Log. If someone could point me in the right direction I would appreciate it.

I don't seem to be able to receive an alert when the host computer goes down, but I think that is because the systems were capable of rebooting in less than a minute so I added a boot delay. I'm hoping I'm missing a better trigger of host reboot or shutdown than the no data option. If someone could point me in the right direction I would appreciate it.

I don't seem to be able to find reports that show the alert duration, outage duration, or PC reboot times. All I can find so far is Last Boot time. If someone could point me in the right direction I would appreciate it.
SysAid Product Manager Community Manager
5260
 
Hi Tim,

Measuring the duration of these events is not currently possible, so I can either move this thread to the Feature Requests forum, or if you're interested in a special project, perhaps it could be developed by our Professional Services team. If you're interested, please contact your account manager to discuss the topic.

Let me know either way

Cheers,
Danny
SysAider
3
 
Thanks for the reply Danny.

If I understand correctly I should be able to see downtime duration of an asset, but not of monitored services or processes. Professional development work or a feature request would be the next steps to address this part. I'll hold off on the feature request for now, but I will ask my account manager about the other option.
SysAider
3
 
Here is where I think I am at:

1. Monitoring Event Log is missing events. Need to determine next steps.
I've tried creating a server template and linking it to one asset instead of a workstation template, but that has not seemed to make any difference.

2. Monitoring Event data is not accessible in reporting. This is by design.
I am now seeing Weekly and Monthly graph for some records in the Monitoring Event Log but the data seems to have gaps and accuracy issues. We'll likely go the professional services route if the cost is reasonable and we feel we're accurately and reliably capturing the data.

3. Downtime for assets is not working at all. Need to determine next steps.
Boot delay has not helped. Not sure if I have a configuration issue.

My account executive has put me in touch will support and we have a call set for tomorrow. Any tips or suggestions in the interim would be appreciated.
SysAid Product Manager Community Manager
5260
 
Interesting. I'd suggest working on this with our team to see what can be done, apart for the topics covered by PS.

I welcome you to update here once solutions are found.

Thanks,
Danny