Agent Software when switching from Premise to Cloud

 
Author
Message
Pat
SysAider
8
 
We recently switched from premise to cloud, and have several remote sites where we manually updated the existing version of the Sysaid Agent software with the new account information. Everything populated correctly in terms of asset management, but somehow the SysaidRCC Remote service seemed to completely disappear on all of those systems. I checked the logs and found the following:

07/10/19 13:07:55:347 [E] ExternalCallServiceControlInterface::StartService Error Description
Failed to open service SysAidRCC Remote
Operating system error code: 1060, Description The specified service does not exist as an installed service
Stack Trace
LaunchRemoteControlConfirmation:reparationForStartRemoteControl
RemoteControlHandler::LanchRemoteControl
RemoteControlHandler::InvokeAction
RemoteControlDevice::InvokeRemoteControl
RemoteControlDevice::StatusChanged
VisitDeviceManagerImpl::Visit
RemoteControlVisitor::accept
HandleAgentMsgQMgr::HandleHttpCompilerCommandMsgQ
AgentHttpCompiler::InvokeDelegateFunction
AgentHttpCompiler:repareDeviceOperationCommands
AgentHttpCompiler::HandleMessage
AgentCompilerBase::OnReceive
HandleAgentMsgQMgr::HandleMessage
HandleAgentMsgQMgr::Run
ExecutionContext::RunInternal
ExecutionContext::Run
ExecutionContext::Run
ThreadHelper::ThreadStart

Reinstalling did not resolve the issue until we did a total uninstall of the Agent software then rebooted and installed a fresh copy. Is this something someone has run into before and if so, can it be fixed without having to manually uninstall/reinstall?